Home Forum XMEGA Xminilab update firmware on OS X
 Gabotronics Forum :: XMEGA Xminilab
Welcome Guest   
 Subject :update firmware on OS X.. 2016-01-01 11:45:11 
Joined: 2016-01-01 11:03:16
Posts: 1
Location: The Netherlands

Hey all,

I just wanted to report that I successfully flashed the XMinilab firmware from my Macbook Pro using a usb cable so wanted to document the procedure. On windows the recommended way to do this is with the Atmel FLIP program, but there is an alternative for Linux and OS X: dfu-programmer.

The biggest hurdle is to compile dfu-programmer from source. These are the steps I took:


  1. Download the latest version of the firmware. Check the manual to see which hardware version of the board you have and use the appropriate firmware.
  2. You'll need libusb so install it via Homebrew:
    $ brew install libusb
  3. You'll also need autoconf and automake:
    $ brew install autoconf automake
  4. To get dfu-programmer to compile I ended up using this fork, b/c the official version couldn't find my libusb. (I've notified them about this here) So download the fork and follow the compilation instructions in the README.
  5. Check that dfu-programmer is installed correctly by running:
    $ dfu-programmer --help
  6. Connect the XMinilab to your Mac with a USB cable, while holding down K1. A red led should light up.
  7. Now to do the actual flashing run these commands from inside the directory containing the firmware files:
    $ dfu-programmer atxmega32a4u erase
    $ dfu-programmer atxmega32a4u flash xminilab.hex
    $ dfu-programmer atxmega32a4u flash  --force --eeprom xminilab.eep
    $ dfu-programmer atxmega32a4u reset
  8. The XMinilab should now reset and show the new firmware version on startup.



This procedure worked for me with an XMinilab v2.3 and a Macbook Pro running OS X 10.11.1 (El Capitan).

It is probably also possible to erase the eeprom before writing the new one, in which case you won't need the --force flag but I haven't tried that. Likewise, I think it's possible to omit erasing the firmware before writing it if you do use the --force flag. The steps that I wrote down is how I did them.

Hope this helps someone,


IP Logged
Page # 

Powered by ccBoard