Home Forum XMEGA Xprotolab Dead Xprotolab plain ??? (FIXED)
 Gabotronics Forum :: XMEGA Xprotolab
Welcome Guest   
 Subject :Dead Xprotolab plain ??? (FIXED).. 2018-06-18 04:16:14 
Joined: 2018-06-18 03:52:07
Posts: 2


My brand new Xprotolab plain (bought in your french distributor store) worked for 5 minutes (using Windows 10, xscope + driver install was OK) and was very promising for a total newbe on MCU programming like me.

But when I started to use the logic analyzer (on a NodeMCU output => ESP8266 with 3.3v level for all GPIOs) Xscope freezed. I restarted everything but since, the xprotolab doesn't light up anymore : I have only 2/3 red light flashes and no more green light.

As I though I erased the firmware or something, I followed various instructions about how to restore it : BTW it's not well explained : do I have to link pin 1 to pin 6 or do I have to ground pin 6 to GND, as I have seen on another forum message ???.

  • I tried with FLIP (hard to find since the Atmel site doesn't exist anymore ... by the way you can find Flip installer for a version working with Windows 10 here : thank you archive.org). USB connection doesn't work, and I got a missing dll error. It's impossible to install the USB driver provided with FLIP. But Zadig is still able to "reinstall" the driver with success (and the device is seen in windows as "xscope"). And windows seems to "see" the xprotolab in some way.
  • I tried also on linux Ubuntu, but AVRDUDE says that there is no available driver for the device.
  • I have tried on various PC without more success : still 2 / 3 red light flashes, no green light.

So I really don't know how to fix this. Maybe it's the bootloader which is erased, but I don't have a PIC programmer and I don't expect to pay 20€ or something to buy stuff for fixing a 20€ device ... Or maybe I can try with a USB / TTL adaptor (I have one based on CP2104) ?

Is my protolab fully dead ? Did I missed something somewhere on how to fix this ?

Thank you a lot for any help provided

IP Logged
 Subject :Re:Dead Xprotolab plain ???.. 2018-06-18 10:47:31 
Joined: 2018-06-18 03:52:07
Posts: 2

(This is an edited answer as my first one was providing wrong details)

So I finally find the details I needed, and was able to fix the Xprotolab Plain :-)

Everything provided in documentation about firmware update is OK, except that the details on "what is the PIN 1 / 6 of J8 connector" are missing.

I did a (fixed) pin diagram : I'm sharing it here, this time it seems to be OK

So the J8 connector is the extension port, not soldered and with only surface mount soldering points, next to the MCU. You have to solder a connector here (for example, a low-profil 1*6 connector is perfect) and "sacrifice" the PDI connector (actually, you will never use it if you don't have a PDI compliant programmer). Then you will be able to link PIN 1 to 6 in it and once you have connected USB, you have to remove the link.

After that, follow the instructions. As the Atmel website is gone since december 2017, you have to search into archive.org for the FLIP tool . Don't forget to use the USB driver provided with FLIP when your computer identify the device, not the WinUSB driver from Zadig tool.

Once the firmware is updated, this nice little device is back to normal :-)

IP Logged
Page # 

Powered by ccBoard