Home Forum XMEGA Xminilab Nice product
 Gabotronics Forum :: XMEGA Xminilab
Welcome Guest   
 Subject :Nice product.. 2016-09-06 09:17:45 
Joined: 2016-09-06 09:02:59
Posts: 2

Hi there,

after updating the Firmware (the Xminilab was sitting some years on the shelf and waiting) I got the USB driver

working and the software is working now in windows. It is great ! Some people tell it a toy because a real scope for them is something with 4 channels and some Gs/s and of course costs some kilo $. But if I just want to check

some low frequency this is all I need (just 0.2 watts instead of 50W, working from battery and transportable).

I get a signal generator and a 2 channel meter etc. And the software for pc is nice. Very well done.

I have an ARM Linux board and tried to run the software (as shown with ODROID) but had 2 problems :

-  when connecting I see a full speed USB device but no /dev/ttyUSB0, where is the problem ?

- when I tried to install QT5 I get an error

How can I just get a screen copy to a file as shown in the manual (with stty) ?

Thanks for help


IP Logged
 Subject :Re:Nice product.. 2016-09-06 19:57:45 
Joined: 2012-04-02 15:42:39
Posts: 463
Location: Sarasota, FL

Hi! Thanks,

I'm not a Linux user, but you will find some tips in the forums, and on this page:



IP Logged
Gabriel Anzziani
 Subject :Re:Nice product.. 2016-09-08 00:56:50 
Joined: 2016-09-06 09:02:59
Posts: 2
Thanks for the quick response. I found an error :

the device is no ttyUSB via USB and a screen dump is only via serial port. So I tried on the ext Interface but it didn't work.

In the manual it says I have to stty ... and then rx ...
But in the command section it is shown I have to send a "C" command for screen copy. So how can this work without sending the command ?
IP Logged
Page # 

Powered by ccBoard